Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Converting database from Antelope to Barracuda for Moodle

I just installed the latest version of Moodle with Installatron. There was a mention of converting my database from Antelope to Barracuda. How do I do this? I have seen some tutorial regarding running a Php compression command. I know enough stuff to ticker but I'm a little lost at the moment.


you can install latest moodle on shared hosting by by changing in config.php file.


dbcollation' => 'utf8_unicode_ci'


for details:

View solution in original post

Community Manager

Hi @themoltron. Welcome to GoDaddy Community! In researching this, it looks like this is something you may be able to do via command line tools provided by Moodle. This article explains what can be done. There is a section on updating the database. Based on what I read, it sounds like you'll need to access your account via SSH to use these commands. That is possible on our Linux plans. However, I'm not 100% sure you'll have sufficient privileges to run the scripts mentioned in the article above. I'd suggest familiarizing yourself with SSH commands as well as the commands in the article I shared and give it a try. You can find information on how to connect via SSH in our Help Center


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.

I tried the commands from the guide via command line (I'm on a shared hosting), the commands are these:

  • cd /home/<user_name>/public_html
  • php admin/cli/mysql_compressed_rows.php --list
  • php admin/cli/mysql_compressed_rows.php --fix

But the last command failed with the following message:

Cannot change GLOBAL innodb_file_format setting, use --showsql option and execute the statements manually.!!! Error writing to database !!!

So I tried '--showsql' which returned the following SQL query:

USE i3852357_mood1;
SET GLOBAL innodb_file_per_table=1;
SET GLOBAL innodb_file_format=Barracuda;
ALTER TABLE mood_data ROW_FORMAT=Compressed;
ALTER TABLE mood_data_fields ROW_FORMAT=Compressed;
ALTER TABLE mood_enrol_lti_lti2_consumer ROW_FORMAT=Compressed;
ALTER TABLE mood_enrol_paypal ROW_FORMAT=Compressed;
ALTER TABLE mood_lti ROW_FORMAT=Compressed;
ALTER TABLE mood_user ROW_FORMAT=Compressed;
ALTER TABLE mood_user_info_field ROW_FORMAT=Compressed;

Then tried to run it via phpmyadmin, but I got the following error:

SQL query:

SET GLOBAL innodb_file_per_table =1;

MySQL said: Documentation
#1227 - Access denied; you need (at least one of) the SUPER privilege(s) for this operation 


I guess I'll just ask for a refund and try on amazon AWS.

This is so disappointing! Man Sad

I'm facing this same situation on a fresh Moodle site today.   Have there been any updates to resolving this?  Anyone with success here?

I am facing the same problem after doing a fresh installation. I didn't think that I would have to pay money to go through a course in Computer Science. This is a complete joke. I am going to ask for a refund and discontinue the service. Totally, ridiculous. Perhaps Godaddy should think about getting in some other business and let the real folks who have interest in meeting the needs of the customer run the market.

I'm also facing the same issues. Unable to upgrade to a secure version of Moodle because despite having your "Deluxe" hosting option, I have no permission to change the DB format. Will probably also have to seek other hosting options. Disappointing. 

today i installed latest version of moodle ( on godaddy shared hosting. following link may be helpful for your to resolved the issue.


Did you ever find a solution?

you can install latest moodle on shared hosting by by changing in config.php file.


dbcollation' => 'utf8_unicode_ci'


for details:

View solution in original post