cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

"Sorry, this file type is not permitted for security reasons."

"Sorry, this file type is not permitted for security reasons."

 

This error keeps coming up on my logo upload form when uploading .ai, .eps, or .svg files:

www.runback.ca/uploads

 

Customers currently have to zip the files in order for it to work, but most of the files I receive are .ai or .eps.

 

How can I get this error to go away?

1 ACCEPTED SOLUTION

Ok so doing a quick google search - this is an issue with WordPress specifically

Here is a Gravity Forms Article - 

https://docs.gravityforms.com/permitted-file-types-for-uploading/

 

As the article mentioned these plugins may not work due to WordPress Security code. I tested the first one which was updated about a month ago, but couldn't get an SVG file to upload via  the media library or gravity forms.

 

I also tested a couple of methods with adding a custom function  - It looks like because WordPress (Core) is locked down on this.

 

Gravity Forms does have a DropBox Add-on - I had the same result - You might want to reach out to Gravity Forms support to find out if there is a way that if using the DropBox Add-on it can bypass the local upload issue

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

5 REPLIES 5
Super User IV

@Rnbck 

Are you having this issue in the admin (Media Library) or on the front end of your site on the order form. 

 

If you are having this issue on the order form (https://runback.ca/createyourdesign/)  I would take at your Gravity Forms settings to make sure you are allowing the file types you are asking about.

 

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

It’s on the front end. If you try to upload an Adobe Illustrator file or an .eps file it gives the error message.
www.runback.ca/upload

The Gravity Forms settings are set to allow any file and I’ve tried just allow these types as well.

It seems this is a WordPress security issue from what I’ve read, but I’ve been unable to locate a solution and I’m not sure who to talk to about fixing it.

Ok so doing a quick google search - this is an issue with WordPress specifically

Here is a Gravity Forms Article - 

https://docs.gravityforms.com/permitted-file-types-for-uploading/

 

As the article mentioned these plugins may not work due to WordPress Security code. I tested the first one which was updated about a month ago, but couldn't get an SVG file to upload via  the media library or gravity forms.

 

I also tested a couple of methods with adding a custom function  - It looks like because WordPress (Core) is locked down on this.

 

Gravity Forms does have a DropBox Add-on - I had the same result - You might want to reach out to Gravity Forms support to find out if there is a way that if using the DropBox Add-on it can bypass the local upload issue

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

I actually just tried a plugin called WP Add Mime Types and it worked for ai, eps, svg, and ps files.

All I had to do was add the plugin and then add those file types into the MIME Type Settings in the Settings tab on the left of the WordPress dashboard. Very simple and it actually worked this time. No other plugin worked for me, but this one did.

Good luck!

Glad that the other plugin worked for you  - Have a great day.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community