cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted

Renewed website and domain and when visiting site all I see is a blank page

I just renewed the website and domain name several days ago, and still when I try to visit the site (karennisdc.org) it comes up as blank.  Have seen some people with similar problems on this forum, and have noticed a few solutions having to do with DNS.  Not a very tech savvy individual, so not entirely sure what that means or how to use it to get the page back up.

 

Any and all help/advice would be greatly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Employee
Employee
Solution

Re: Renewed website and domain and when visiting site all I see is a blank page

If you renewed your domain and website, then as long as everything was connected correctly (DNS basically = domain name settings, like what it's connected to), it should come back up within an hour. Since you're still getting a blank white screen on karennisdc.org and www.karennisdc.org after several days, that means either something is wrong with the content of the website (possibly it didn't get renewed since the domain and website are separate) or it's just not connected. Since no error is coming up, I would call support just to have them check. They're open 24/7, including holidays, and can quickly check on that for you and make sure everything is good.

View solution in original post

1 REPLY 1
Highlighted
Employee
Employee
Solution

Re: Renewed website and domain and when visiting site all I see is a blank page

If you renewed your domain and website, then as long as everything was connected correctly (DNS basically = domain name settings, like what it's connected to), it should come back up within an hour. Since you're still getting a blank white screen on karennisdc.org and www.karennisdc.org after several days, that means either something is wrong with the content of the website (possibly it didn't get renewed since the domain and website are separate) or it's just not connected. Since no error is coming up, I would call support just to have them check. They're open 24/7, including holidays, and can quickly check on that for you and make sure everything is good.

View solution in original post